This forum is in read-only mode. Please continue to browse, but replies are disabled for now. Why?

EcoSmart Battery Upgrade 36v To 48v Problem


I recently tried to add an extra 12v battery to my Razor ecosmart electric scooter as described in the video below. After doing all the steps in the video, my scooter now no longer turns on, although does when plugged into with the charger. We've tried everything; grounding one of the wires to frame, plugging in a saudered xlr connector to the charging port, all electric connections flowing correctly, ect. Any suggestions or guidance would be much appreciated. Thanks.

Usually when a scooter only turns on when the charger is plugged into it that indicates a problem with one or more of the batteries, or the power from the battery pack is not reaching the wiring harness or controller. 

We would start troubleshooting by turning the power switch on, twisting the throttle, and testing the Voltage of each individual battery. If one of the batteries has a significantly lower than normal Voltage it may be the part that is causing the problem.

If you have photos of the wiring then we would be glad to take a look and see if we notice anything that is miswired and causing the problem. 

The frame should not be grounded so if it is then we recommend ungrounding it. 

Please let us know how it goes.

Thank you for your response. We tested all of the batteries, and found them all to be at proper levels. In the process though found that the fuse was blown. We're newbies and didn't think to check that in the beginning. I believe that while I was doing the initial conversion of wiring, I must have touched the positive and negative wires leading to the main harness together and blown the fuse. I don't know for sure if this cause of the problem but I just ordered a few fuses from you to find out. Thank you for having this forum available for everyone. It's very helpful, and I'll update when I get the fuses.

Yep, that is indeed what happened.

All it need was new fuse.

Thanks for your help!

Thanks for letting us know. Great to hear that the problem so simple and easy to fix. 

Login or Signup to post a comment