1-800-908-8082
 
8am-5pm Pacific Time Monday-Friday
Start a new topic

terminator electric scooter will not carry a load even itself

Terminator electric scooter ES-04 will run on bench but will not go on its on while on ground and will not carry load at all. Checked throttle and it appeared fine (unit was not running when brought to me) batteries would drop below 20 volts replaced batteries.....replaced control module and just replaced motor. Have also loosened brake all the way out. Any ideas on this
Battery voltage is 25.5 with nothing running. Battery voltage is 24.9 with motor running wide open while on bench. Battery voltage is 25.4 while trying to run from stop with boot resting against tire. Motor voltage from controller while stopped is 0. Motor voltage from controller while wide open with no load varies between 24.7 and 25.3 and with boot against wheel it is 23.7. Motor voltage at 1/2 throttle is 12.2 and drops to 1.1 when boot is applied to wheel. Motor will not go at all from stop with boot against wheel. All of this done with scooter off of the ground
The first thing I would do is connect the battery pack directly to the motor and put your boot against the wheel to see if the rear wheel is getting good power then. If the wheel gets good power with motor connected directly to battery pack then the problem would have to be in the controller.

 

Can not stop wheel when straight wired to battery. I have video on my phone with the voltmeter attached and you can see what it is doing. The file is to big for my phone to attach it to a message so I will have to download the sd card to my computer to send it. The speed controller was just recently purchased and the order number was 72174.

attached is the video

mp4
Happy new year! I saw the video you attached. Is the Voltmeter connected to the battery pack leads or to the motor leads?

 

Happy New Year to you as well. The leads are connected to the motor leads. I can do a video with it connected to the battery if you would like to see that

Yes, that would help me diagnose the problem if you could attach a video with the Voltmeter attached to the battery pack leads during the test. Thank you.

Attached is a video with the test leads attached to the battery pack.

mp4
Thanks for attaching the video. I see the battery pack is not dropping too much Voltage under load so the batteries are good. I am pretty sure it is the controller. I will send you a new SPD-24250 controller tomorrow morning to replace the one that you have. Hopefully that will do the trick. Please let me know how it goes after installing the new controller.

 

Received controller installed it on the scooter and it is presently doing everything it should. Thanks for all of your help
Your welcome. Great to hear that the problem is solved. Thanks for letting me know.

Login or Signup to post a comment