This forum is in read-only mode. Please continue to browse, but replies are disabled for now. Why?

Freedom 946 C scooter will not charge green light only illuminates on adapter

I have a Freedom 946 C scooter that has been in storage for maybe 5-7 years.  Purchased new batteries and started to charge and the red light came on briefly for maybe 30 seconds and turned green.  I figured the batteries came charged, the kids rode it for about 15 minutes til the batteries ran out of power.  Everything worked fine lights signals etc.  Plugged in to charge and the green light illuminates and will not charge the batteries.  The red light will not come on.  I'm sure the batteries are wired correctly in series as all I did was put the new batteries in.  I can buy a new AC adapter but don't believe that is the problem.  Any idea what could be wrong or how could I troubleshoot?  Surely the new batteries are not defective.  Also is there an external charger that can be used to charge these batteries individually if necessary?

Thank you

That is perfectly normal for new electric scooter batteries to only take around 30 seconds to recharge before they are used for the first time. Since the charger light turned red and then green that is a very good indication that the charger is working properly.

It sounds like the power from the charger is no longer reaching the battery pack so they are not being recharged. This could be caused by a loose connector or broken wire between the charger port and speed controller, a defective charger port, or a defective charger or plug on the charger. I would test the battery charger and charger port for their Voltage. The battery charger plug is easy to test because it has holes in it to to stick the multimeter probes into. However the charger port has prongs which are easy to short circuit with standard multimeter prongs. I recommend wrapping electric tape around the metal probes leaving only the end exposed before testing the charger port to avoid short circuiting its prongs.

If the scooter has a 24 Volt battery pack then you should get a little over 24 Volts at the charger port and around 29 Volts at the battery charger plug. Performing these tests should help pinpoint the problem. Please do not hesitate to let me know if you have any further questions after performing the tests.

I finally got a multimeter and was able to check the two items you mentioned above.  I do get about 29 volts from the battery charger plug.  Not positive i'm doing it right but with the batteries connected I don't seem to be getting any voltage at the scooter charger port at all.  The batteries are pretty dead I have checked it with the key off and key on the same reading no voltage.  Just to check I checked the batteries and are getting a little higher than 12 volts on each battery and both wired on series about 25 volts.  I guess I will check the wires for bad connections or broken but it seems connected the the charger port and to the controller.  Is there a way to check the charger port itself?  Also could the controller be the cause of it not charging?

Thanks for all your help

That has to be the problem, if you do not have Voltage present at the charger port then the battery charger is not connecting to the batteries and can not charge them.

To test the charger port and controller I would disconnect the charger port from the controller and see if Voltage is present at the charger port connector on the controller. If no Voltage is present at the controller's charger port connector, assuming the battery pack is connected to the controller and the controller is receiving power from it, then that would indicate a problem with the controller because it is not passing the battery pack Voltage to the charger port. This could be fixed by replacing the controller, or bypassing it and wiring the charger port directly to the battery pack.

On the other hand if you find Voltage present at the controller's charger port connector, then that indicates a problem with the charger port, and it needs to be repaired or replaced.

Please let me know if I missed a question or if you have any further questions.

I think I understand what you are saying I will check those items, checking for voltage at all connectors leading to the controller and to the charger port. If voltage to the controller then no voltage leaving it I know the controller is most likely bad.  Also say the controller is bad, from what your saying can you just bypass the controller and wire direct from the charger port to the battery and connect the battery charger and charge this way assuming the charger port on the scooter is ok?

This may be the easy way to charge the batteries directly if this is safe.

Thanks again for all the help

OK to follow-up before you answer the above.  I checked the connections I have power going into the controller.  The two 16 gauge wires coming out of the controller has no voltage and these go to a connector then the other side of connector two 14 gauge wires that go to the charger port on the scooter. No voltage sounds like the controller is bad.  Everything else works lights signals motor ETC.  If I can find the exact controller I will buy one. In the meantime please answer my question above how about running two wires from the charger port to the batteries still wired in series and charge it with the normal scooter battery charger pluged into the charger port as you normally would.

Thank you,

Yes, you can bypass the controller and wire the charger port directly to the battery pack. That is how Currie Tech has been wiring their electric scooters and bikes for the last 15 years so it is a time proven way to do it. That way the controller is eliminated from the charging system so there is one less thing that can go wrong with it.

OK I have wired two wires from the charger port to the battery.  I pluged in the battery charger to the charger port and the green light came on the battery charger.  I plugged it into the wall outlet and the red light illuminates, seemed to be charging.  After about 15 minutes the red light flashed to green and flashes back to red about every second or two.  Alittle worried something is wrong it should charge normal I would think and take 6-8hrs to charge the batteries.  Could it be charging the batteries way to fast?  What I did is run two separate wires from the scooters charger port to the battery red from charger port to red terminal of a battery and black to black on the other battery with a jumper wire from the negative terminal of the first battery to the red terminal of the other battery connecting the two batteries in series together.  So red wire into the first battery from the charger port and the black wire from the 2nd battery that goes back to the charger port. 

Something must not be correct. Any help would be appreciated.


I have disconnected it for now.  I tried plugging the normal wires back on the batteries to try the scooter.  It seems to be dead no power. I did cut the 16 gauge wires off coming from the controller as these are not connected to anything as they originally went to a connector to then 14 gauge wires and then to the scooter charger port. One thing I did notice and didn't like is when I plugged the charger port wires on the battery it sparked alittle when plugging the last wire on the battery.  Worried its trying to short out so disconnected it.  Anything I could test to see what is wrong?  I would think how I wired from the charger port to the batteries is correct but who knows.

Thank you,

From the above post I used a multimeter and checked the battery voltage from how I had it wired.  It was around 25 volts tested at the wires leaving the batteries so it looks like it was wired correctly in series.  I then went to check the voltage at the scooter charger port male prongs and at first touching the a prong where the red wire connected and the prong where the black wire connected and if seemed the multimeter indicator wanted to go backwards below 0 not forward as it should to go to 25 volts.  Thought that was odd.

Then I probed the red wire prong and the prong with no wire connected and got a big flash I must have touched something and it shorted out even damaging one the the multimeter prongs as I didn't take your advice above about taping them.  I may have ruined the charger port or maybe it was already been defective but now most likely bad since I shorted it.  Really don't understand if I had 25 volts coming from the wires and originally wasn't getting a reading at the prongs.  Any ideas what to do next?

Are there chargers to purchase like a trickle charger that would work just to charge these batteries off the scooter?  Still wondering when I reconnected the batteries to the scooter to try it had no power you would have thought the batteries would have charged alittle.

Thank you,

I may have fried the controller totally I wired the 16 gauge wires back to original just to see if it would show any power. Turned key on and nothing The batteries are holding over 25 Volts should show something.  Not really sure what to do now, was hoping to get some use from it.  Everything worked when I put the new batteries in drove it til it died of no power.  The batteries ran out of power and never could charge them.  A new controller maybe but don't like the idea of trying to wire a universal one.  I definitely ruined the charger port it melted off part of a prong when I shorted it.  Any ideas would be helpful.


I guess I rambled on a little in the above posts but was hoping to get some answers but I'm kind of committed to get this so please try to answer the questions below.  It is appreciated.

I think I will replace the controller as I have no power.  Please give me the part number of the one to purchase from you?

Also I need a charger port part number?  Maybe they are generic all fit all its a 3 prong.

The fuse seems ok not positive any idea why I have no power at all now?

Thank you,

Sorry for the late reply we have been very busy this week. It sounds like you wired the charger port correctly to the batter pack. If you want to attach a picture I could confirm. If the batteries were only briefly used then a 15 minute recharge time is perfectly normal. A 6-8 hour charge would be for a battery pack that was completely exhausted after being used for 30-60 minutes of ride time.

It is normal for there to be a spark when connecting a controller to a battery pack, they all do that.

When testing Voltage at the charger port. If the multimeter shows a minus Voltage reading the meter probes may be touching the wrong pins, if you reverse the pins the probes are touching the meter will indicate a plus Voltage reading. Sorry to hear about the short circuit that occurred when testing the charger port. These kind of things happen to the best of us sometimes. Charger ports are not too expensive ans usually easy to replace.

You could charge the batteries off the scooter however I do not recommend using a trickle charger because they are usually too small for the size batteries in the scooter. Also the wiring harness connectors are not designed to be taken on and off the batteries very often and will need frequent replacement if used in that manner. the best way to charge the batteries is on board the scooter.

After the new batteries were installed and the scooter was running, how long did it run for, and did it slow down before it stopped running, or did it just quit running all at once without slowing down?


After installing the new batteries the scooter ran for about 10-15 minutes.  It slowed down before it stopped running completely.  As for charging the scooter with the batteries wired directly to the charger port as I stated the charger adapter light stayed red for maybe 15 minutes then flashed to green and back to red about every second or two that's when I felt something was wrong does that mean they were recharged?  I thought it would go back to a solid green light either-way I still had no power.  Is this correct to have 29 volts going to the batteries from the charger directly with 24 volts from the batteries? When I connected the batteries back up to the scooter and turned the key on it had no power the red indicator light came on briefly for a second then went out like it was dead.  Now the red indicator light will not come on at all that's concerning as I wondered about the fuse blowing but when I shorted it out with the multimeter but the only thing connected was the batteries to the charger port.I appreciate your help any ideas what I should do next?  

I really don't have a problem purchasing a new controller and charger port at this point just hope that finally fixes the problem because everything worked when I first put the batteries in I just couldn't recharge them.  Could you let me know which controller part number to purchase from this site.

Usually if the scooter slows down before it stops running it is because the batteries ran out of power. When the controller goes bad the scooter stops running all of a sudden, usually without slowing down, unless the battery pack's charge is wearing down at the same time.

It is normal for electric scooter chargers to alternate between red and green during the final phase of the charge. Most chargers start off red, then alternate between red and green, then go to solid green when the charge is completed. If the battery charger alternated between red and green then the batteries should be around 95% recharged.

Before installing a new controller I recommend load testing the battery pack to make sure it is not the problem. I know they are new batteries but even new parts can be defective sometimes. Before load testing them you will need someway to recharge them though because they will need to be recharged very soon after putting a load on them so they do not become damaged from leaving them in an uncharged state for an extended period of time. I would start by load testing them on the scooter by reading their Voltage with the scooter power off, and then reading them again with the scooter power on and throttle fully engaged - the packs Voltage should not drop more than 1-2 Volts and should not drop under 23 Volts with the scooter on and throttle engaged.

If the battery packs Voltage does not drop at all when the scooter power is on and throttle engaged, that points towards there being a problem with the electrical system (switch, fuse holder, wire harness, wire connectors, controller, throttle, etc.). However if the battery packs Voltage does drop under 23 Volts when performing the test that points towards the battery pack having one or more defective battery in it.

Unfortunately Freedom Scooters is no longer in business so original plug and play controllers are not available anymore. A universal controller would have to be custom installed to get the scooter working if the controller is bad. For this job I recommend our SPD-24500B speed controller which is available on our 24 Volt Speed Controllers page.

Login or Signup to post a comment