This forum is in read-only mode. Please continue to browse, but replies are disabled for now. Why?

Crazy cart not working

My son has a crazy cart that he got for Christmas last year, so almost 8 months old. I believe it is version 5, but not positive.  It has run great and then last week it just stopped working.  Nothing happens when he hits the gas.  No click, nothing.  Both batteries a believe are charged.  I have taken it apart and see not wire damage, and every thing is connected.   I have a voltage tester, but I really have no idea of where to put the leads on to check for anything.  I was thinking it might just be the control module.  Any help would be great.


Crazy cart has does not run. Battery is fully charged. When pedal is depressed can hear a clicking noise, but no movement. Does not appear to be any broken wires. The Pedal was taken apart, the one magnetic strip seems ok. The kids told me before it stopped working that when they turned the steering wheel to the right it would go left (I can't verify this!). Any ideas?

Sounds most likely to be a worn out or faulty battery pack, or a broken motor wire.

The clicking sound heard when the throttle is pressed should be coming from the controller. If the battery pack is dropping too many Volts when it is under load the controller will click, however if one of the motor wires is broken under its plastic insulation then the controller would also click.

I would start by plugging the battery charger into the cart, letting it charger for an hour or two, and then leave the charger plugged into the wall and cart while trying to run the motor. I would prop the cart up on something that will elevate the wheel off the ground during this test so the cart can not move. If the motor runs when the charger is plugged in then that points towards a worn out or faulty battery pack.

If the charger test does not help then while the cart's wheel is propped off of the ground I would turn on the power switch, press the throttle, and slowly turn the steering wheel from far left to far right and see if the motor momentarily turns on while the steering wheel is being turned. If it does then the problem would have to be a broken motor wire.

Please let us know how it goes.

Thanks for replying. Tried again no go, left the switch on for 30mins depressed pedal and it worked. Turned off switch for 30 mins then back on and it did not work. Left switch on for 30mins tried and it worked. Repeated this procedure for the evening with the same results. Any ideas ?
If the problem were the batteries then the test results should be the same every time. Since the problem is intermittent it sounds more like a broken wire or faulty connector type of problem.

There is a light inside of the power switch which can be used to help troubleshoot the problem. If the power switch light stays on when the motor does not run then the problem would be after the switch, and if the power switch light turns off when the motor does not run then the problem would be before the switch.

A internally broken motor wire (copper wires broken underneath the plastic insulation) is the most common type of intermittent problem with Razor Crazy Carts, so I would start with diagnosing the motor wires.

Have you tried slowly turning the steering wheel back and forth all the way from far left to far right with the power on and throttle pressed to see if the motor cuts in and out at any certain spot in the steering angle?

I was driving the crazy cart when suddenly stopped. Battery is ok (tested), and found no signal to the controller/pedal, so I replaced the controller/pedal kit without any luck. I noticed that the light of the switch (On/Off) tends to fade and blinks without holding full brightness, so I replaced the switch but still is not running. Thoughts? Thank you

Hi Andrew, when the light in the switch fades such as you described that points towards the battery pack not being able to maintain enough Voltage when it is under load.

When you tested the battery pack was it under load or did it have no load on it? And what was its Voltage level during the test?

Login or Signup to post a comment