1-800-908-8082
 
8am-5pm Pacific Time Monday-Friday
Forum Notice: This forum is currently in read only mode because its moderator is on vacation. Please check back after a while to be able to post new topics and reply to existing topics.

Scooter suddenly didn't start

Hi, I have a 60V Viper Blade scooter with lithium ion batteries. Once when I tried to turn on the scooter it didn't work so I opened up the compartment and the connecting positive red wire from the battery wasn't in full contact with the other red wire coming from the rest of the circuit. So I pushed it in further and the scooter was working. Now a few days later it doesn't work at all and I have a feeling it has to do with the connectors from the battery to the circuit. The battery is working as when I measured thr voltage of the battery it was an appropriate 62V however when I connected the battery to the circuit and measured the voltage it measured around 30V which is way less than the cut-off voltage of 48V hence the scooter doesn't run. As I said previously the scooter didn't run as the positive wire was loose and when I pushed it in further it worked so are the connectors in need of replacement? Maybe they are just damaged. Could it also be an issue with the transformer? When I took the wires from the little black cover itself and connected them it still didn't work. I attatched a photo so you can see what I'm talking about.
Nevermind I went to an electrician and he tested the battery. Turns out the battery dead :(
Glad to hear that you have solved the problem. Sorry to hear that it was the lithium battery pack though because that is an expensive part to replace.

Login or Signup to post a comment