This forum is in read-only mode. Please continue to browse, but replies are disabled for now. Why?

Razor ground force drifter won’t turn on unlessbplugged in

It ran fine for a day. Now it won’t turn on. If it’s plugged in and I turn the switch on the switch lights up and the throttle lights up. The battery is giving 24 volts unplugged. I checked it with my meter. All the connections are good. I tried a jumper on the brake switch and still nothing. The fuse looks good. I’m lost.... any ideas ??

It sounds like the power from the battery pack is no longer reaching the controller. maybe one of the wires is broken under its insulation, or there is a wire connection problem inside of the controller. Have you tried testing the battery pack Voltage when the battery pack is connected to the controller and the power switch is on? The reason I ask is that maybe one of the batteries has failed and the pack Voltage is dropping down to zero when there is a load on it.

Login or Signup to post a comment