8am-5pm Pacific Time Monday-Friday
Start a new topic

Razor e300 circuit not working.

For a project, we are using razor parts and we bought the electrical parts for the razor e300 and tried to make a circuit. However, our circuit showed no signs of working and nothing has happened. We have already tried many things, like charging it for 48 hours straight and checking loose connections. That made us think that we might have ordered a wrong part. We bought parts from a version 17 Razor e300.and we were using the wiring diagram listed here. One thing we noticed from the troubleshooting diagram was that the throttles lights were supposed to light up, but our throttle didn't even have lights. Is a Razor e300 throttle supposed to have lights on it?. We also noticed that our e-kit's color wires didn't perfectly match up with the wiring diagram. They fit the opposing wires, but the horizontal colors weren't in the right order.

The OEM ekit for Razor E300 version 11 and 13+ has a throttle with no indicator lights and the wire colors between the throttle and controller's throttle connector do not match each other.

This ekit modifies an E300 version 17 to not have throttle lights, and to also to no longer have variable speed control - it will only have off and full speed control with this kit.

If you can not get the motor to spin here are some things to try:

  • If a brake switch is connected to the controller unplug it and see if the motor spins then.
  • Test the power switch for continuity where the controller connects to it to make sure it is working.
  • Test the battery pack's output connector for Voltage to make sure the circuit breaker and wiring are good.
  • Test the battery pack to make sure it has a minimum of 23 Volts in it.
  • Test the battery pack under load and make sure it does not drop under 23 Volts.
  • Test the motor by disconnecting it from the controller and hot-wiring it to a battery to make sure it works.

A good 24 Volt battery pack will have around 27-28 Volts in it after being fully charged.

Please let me know how it goes.

We tried most of those things and none of them worked. (We couldn't do some). However, I was changing some connections and suddenly the on/off switch lit up which was a big step. We then tried the throttle and the control module made a wierd sound, like a doorbell sound. It kept making that sound every time we tried the throttle. We found that hot wiring the motor to the battery gave nothing at all so now we are charging it
Another few things: The on/off switch stopped lighting up when we unplugged the charger. Also there's not supposed to be anything in the circuit breaker, right?

If the power switch light is on when the charger is plugged in, and turns off when the charger is unplugged that is an indication of an old or faulty battery pack or a faulty wiring harness or circuit breaker. If the controller makes a clicking sound when the throttle is twisted that is almost always because of an old or faulty battery pack.

The motor should run when connected directly to a battery pack. If it does not then either the battery pack or motor are not working.

If the controller was clicking when the battery charger was unplugged from the scooter, then power from the battery pack was reaching the controller which indicates that the circuit breaker and wiring harness are good, and the battery pack is bad. If the controller was clicking when the battery charger was plugged into the scooter and the wall, then the problem could be the battery pack, circuit breaker, or wiring harness.

Circuit breakers are self contained and nothing goes into them or can be taken out of them. The Razor E300 circuit breaker has a button that will stick out just a little from its neck when it is not tripped, and will stick out significantly more from its neck when it has been tripped. If the circuit breaker is worn out the button will not stay when pushed in, and will always be in the tripped position.

Please let me know how it goes.
It seems like we are missing a piece in the circuit breaker. Our circuit breaker looked nothing like the picture. it looked like the object in the picture fits in to our circuit breaker perfectly. If that, it would explain everything. The controller does not click when the charger is unplugged so it is probably the battery
Here is what an original Razor E300 scooter circuit breaker looks like.

Sometimes used electric scooters are modified with different parts so if the scooter's circuit breaker does not look like the one in the photo above then someone may have installed a non OEM circuit breaker before you got the scooter.

Since the controller does not click when the charger is unplugged you are definitely on the right track with looking into the battery pack, circuit breaker, or battery pack wiring harness as being the problem.

Please let me know how it goes.
I was just reading your last reply again and after reading "it looked like the object in the picture fits in to our circuit breaker perfectly" realized that someone might have installed a fuse holder into the scooter and it needs a fuse. Here is what most electric scooter fuse holders and the fuse that goes in it looks like.

If the fuse is missing from a fuse holder then power from the battery pack will not reach the speed controller. If the Razor E300 scooter needs a fuse then 30 Amp is the correct fuse rating.
This is all we have for a circuit breaker:
(1.33 MB)

I looked at the image you attached and that is the battery connector that plugs into the controller. The circuit breaker should be attached to the battery pack wires as shown in this wiring diagram.

Do you know of any place where we can buy the circuit breaker? By itself would be ideal.

I do not know of any local stores that would carry that circuit breaker however we sell them in our online store for $5.95. They are item # RAZ-RESET and are located on this page: http://www.electricscooterparts.com/razore300.html

What number amp should we get? It's a version 17
All versions of the Razor E300 electric scooter use a 20 Amp circuit breaker.
We purchased the circuit breaker and we tried the throttle and it finally worked! We'd like to thank you for your help with our project.

Login or Signup to post a comment